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About this Document

This User Manual is intended for users of the DOSRAD application. 

It consists of the following chapters: 

 Introduction 

Gives a general description of the manual. 

 General Principles 

 Gives an overview of the DOSRAD method and functionalities with the 
 different files and modules. 

 Man Machine Interface (MMI) 

 Describes all the elements interfaced with the DOSRAD application. 

 Computation methods 

Presents general computation methods using the different modules: 

o Dose cartography 

Presents the module describing, at satellite or equipment level, the calculation 
of the total dose received on model meshes. 

o Bounding box 

Presents the module describing, at satellite level, the calculation of six 
Aluminium equivalent thickness of any equipment for subcontractor 
specification. 

o Computation point 

Presents the module describing, at satellite or equipment level, the calculation 
of the total dose at one point in the geometrical model. 

 Getting Started with DOSRAD 

 Provides step-by-step instructions for getting started with the DOSRAD
application. 



Reference: MOS.UM.728639.ASTR 

Issue: 4 

Edition: Feb 2012 

Page: 9 of 116

© Airbus Defence & Space 2023 – All rights reserved. Copying of this document, and giving it to others and the use or communication of the 
contents there-of, are forbidden without express authority. Offenders are liable to the payment of damages. All rights are reserved in the event of the 
grant of a patent or the registration of a utility model or design.

OUTGASSING User

Manual

About DOSRAD

DOSRAD is a plug-in application of the SYSTEMA environment. This manual makes therefore reference 
to the modeler, mission and processing modules of SYSTEMA. 

This document presents the DOSRAD software that computes the radiation dose received by electronic 
components located within the spacecraft accounting for the geometrical shielding and the mission dose 
depth curve. 

This manual contains task-oriented instructions which show you how to use the DOSRAD program. The 
different computation techniques supported by DOSRAD are also presented. 
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Glossary

In this User Manual, some terms have a specific meaning: 

Term Meaning 

BULK This container is used to specify the applicative properties of the 
surfaces. 

Local / inherited 
 The “local” and “inherited” notions are explained in the 

SYSTEMA User Guide (Chapter  “Gemetrical model management”) 

Activity In terms of radiation application, the question is to determine whether a 
surface has an impact on the dose calculation. An inactive surface 
does not give shielding to radiation. 

Specific Items The specific items (or virtual nodes) are elements defined in the 
meshing model, on which results are computed (Bounding box and 
Computation point) or allowing to extend standard geometrical 
definition (honeycomb and volumes). 

Referenced shapes When creating a virtual node, the shapes selected for its definition are 
called referenced shapes. These attached shapes modify the shielding 
to radiation in the analysis. The referenced shapes by Bounding Box or 
Computation Point give no shielding to radiation. The referenced 
shapes by Volumes or Honeycomb modify the way the ray-tracing 
algorithm will account for thicknesses. 

Bounding box A bounding box is the virtual target box (6 faces box) on which the 
sectoring analysis will be performed. 

Computation point A computation point is the virtual point on which the Computation point 
analysis will be performed. It is also the attached point at the bounding 
box creation. 

Honeycomb A honeycomb is a specific item allowing to take into account additional 
thickness during ray-tracing. These additional thicknesses come from 
honeycomb panels present in a spacecraft. A Honeycomb specific item 
is a pair of referenced shapes representing the two face sheets of a 
honeycomb panel. 

Volume A volume is a specific item allowing to represent volumes in a 
geometrical model. A Volume specific item is composed of referenced 
shapes defining the border of the volume to be represented. 
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Typographic Conventions

The following typographic conventions are used in this manual: 

Convention Description Example 

Green Used for the DOSRAD-related functions The DOSRAD application is 
interfaced with… 

Blue Used for the SYSTEMA-related functions Within the SYSTEMA processing
tab,….

These colors are used in the diagram of Chapter Man-Machine Interface to 
distinguish the SYSTEMA entities from the DOSRAD ones.

Italics Names of the options related to the 
current entities or filenames 

Fit – Material Filename*– Physical 
properties

Numbered list Procedure containing the several actions 
to be performed 

1. Click the Revert button. 

2. Enter a new value. 

Bulleted list Items list This container will affect the following:

 Dose cartography 

 Bounding box analysis

 Computation point analysis

A warning calls attention to information that is essential to run successfully the 
DOSRAD application. 

A caution calls attention to important information which, if not understood, will 
lead to a conflict or an error. 

A note provides additional information to emphasize or explain important points in the 
manual. 

Cross-reference: prompts the user to refer to a particular section in the manual or to a 
special document. 

* Material Filename" is the name of the material which has been loaded during the SYSTEMA session. 
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Overview

Introduction 

In this chapter the user will find some general principles that he has to know before using 
the DOSRAD files and modules. 

The DOSRAD software evaluates the radiation dose expected in a spacecraft given the 
mission dose-depth curve (computed from in-orbit particle fluxes) and the spacecraft 
geometry including the shielding design. 

Radiation doses result from an incident flux of particles in space, mainly protons and 
electrons, which then propagate through the spacecraft material, generating secondary 
radiation, mainly bremsstrahlung photons (X rays) and depositing dose. Such dose 
calculations are necessary for evaluating the lifetime of electronic components, payload 
damage and hazards to astronauts. Future space programmes will also be more demanding 
in terms of resistance to the effects of the space environment. Long-term missions and the 
use of high-performance technologies all require reliable environment models and analysis 
tools. 

The software is intended to provide a tool for evaluating doses received at points within 
spacecraft geometry. The physical processes involved in radiation transport are complex 
and a rigorous analysis would involve Monte-Carlo methods. However for many engineering 
applications, a more approximate treatment is more efficient. 

The main functions of DOSRAD are as follows: 

 Geometry modeling and physical properties & meshing. 

 Physical simulation: radiation analysis: 

- Dose cartography: calculation of the total dose received on model meshes. 

- Bounding box analysis: calculation of the six aluminium equivalent thickness of 
any equipment for subcontractor specification. 

- Computation point analysis: calculation of the total dose at one point in the 
geometrical model. 
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DOSRAD-Specific SYSTEMA Tabs

Here the DOSRAD package is fed back to the SYSTEMA environment. 

The MODELER, MISSION and PROCESSING tabs have the same layout. 

A detailed table will be proposed in the relevant MMI related sections to describe each 
tab. 

Example 

Here are the options proposed in the Edit menu of the SYSTEMA Mission tab: 

Figure 1 -  Options proposed in the SYSTEMA Mission tab 

For each tab, the menu consists of both general and specific options. 
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The standard options are as follows: 

Edit menu (contains options applicable to entity components) 

Option Used to: 

Enter a specific meshing created for DOSRAD

Select the file to open 

(Not used in the version 4.3) 

Cancel the display and return to the  option 

Issue a warning or provide information on the processed nodes or the 
current configuration. 

The local errors (e.g. a forbidden value) are identified in red. However, 
some elements cannot be automatically returned in error. 

If it is not an error to be locally corrected, a warning displays in the 
lower window. The error is detailed and can be corrected in another 
area. 

Validate the selected component(s) 

The button is disabled if any error is still present in the information area. 
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DOSRAD Modules and Corresponding Files

In this User Manual, the "module" or "DOSRAD module" terms will be used to refer to the sub-processes 
managed by the DOSRAD application, namely dose cartography module, bounding box module,
computation point module.

Each module defines its input files, parameters and output files. 

The parameters of each module will be detailed in the chapters dealing with the different modules. 

The following tables present the different modules and corresponding files: 

INPUT File extension 

Module File extension 

Computation point  
".sysset" 

“.dose” 

Bounding box 
".sysset" 

“.dose” 

Dose cartography 
".sysset" 

“.dose” 
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OUTPUT File extension 

Module File extension 

Computation point 
“.pt.h5”, “.rpt.h5” 

“.pt.log” 

“.pt.out” 

Bounding box 
“.box.h5”, “.rbox.h5” 

“.box.log” 

".box.out"

Dose cartography 
“.map.h5”, “.rmap.h5” 

“.map.log”

INPUT file extension 

The “.sysset” file refers to a mission defined in the SYSTEMA V4 platform. 

The “.dose” file contains the dose depth curve with different types of geometry (solid 
sphere, shell sphere, semi infinite wall and finite thickness slab). 

OUTPUT file extension 

The “.h5” outputs are HDF5 files used for result interpretation. They can also be loaded 
into an HDF explorer. 

The “.log” file provides general information. 

The “.out” files output by the bounding box and computation point  modules are results 
written with the ASCII format. 
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Overview 

1.1 Introduction 

This chapter describes the general ergonomic principles and basic procedures for using the 
DOSRAD application into the SYSTEMA platform. 

The application may be illustrated as follows: 

.h5

Processing 

Modules

.sysset

Post-processing 

geometrical model
meshing & 
numbering

interface

.sysmis

mission

.sysmsh.sysmdl 

Mission

Modeler

- Dose cartography 

- Bounding box 

- Computation point

DOSRAD

Hdf5 results 

Tab

Tab

SYSTEMA

Tab

Applications

Properties

Meshing & 

Numbering 

library 

Symbols Used for

Output files

Tabs

Post-processing

Figure 2 -  DOSRAD within SYSTEMA
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Note that, since version 4.4.2, the Mission is not anymore mandatory for setting a calculation 
as the processing can be directly linked to the meshing file. 
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1.2 In this Chapter 

This chapter covers the following topics: 

 How to perform a radiation analysis. 

 Using the interactive Modeler module. 

 Meshing and numbering. 

 Using the interactive Mission module. 

 Using the interactive Processing module. 

 Post-processing. 
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2 How to Perform a Radiation Analysis

The DOSRAD application is interfaced with SYSTEMA. Consequently, to use the DOSRAD package, the 
analysis must start with the generation of the geometrical model of the space system. 

This first step of the analysis can be performed: 

 Using the interactive 3D MODELER.

A mission can also be designed (not mandatory anymore since version 4.4.2). This second step can be 
performed: 

 Using the interactive MISSION module.

The different steps to build a radiation analysis are performed:  

 Using the interactive PROCESSING module.

As shown in the illustration (Figure 1 - DOSRAD within SYSTEMA), each SYSTEMA
module (Modeler, Mission & Processing) are completed by DOSRAD specific tabs. 

Within the SYSTEMA processing tab, the DOSRAD application is organized into modules, which are 
based on 3 sub-applications and used to manage the DOSRAD entities: 

Computation point: this module is used to calculate the total dose at one point in the 
geometrical model. 

Bounding box: this module is used to caculate the six Aluminium equivalent 
thickness of any equipment for subcontractor specification. 

Dose cartography: this module is used to calculate the total dose received on model 
meshes. It gives dose mapping on surface whatever their shape 
(cone, cylinder, sphere...). 

The above-listed modules are shown on (Figure 11 -  DOSRAD modules). 
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3 Using the Interactive MODELER Module

The Modeler tab is used to work on models and meshing. According to the SYSTEMA configuration, 
some applications can be interfaced with SYSTEMA. In this case, the elements of the geometrical model 
have application-dependent properties. 

These properties can be consulted or modified using the edition window, via a specific tab (called 
“DOSRAD“ tab” in this document). Each application has its own tab. 

For a given application, material files may be required to define the application-dependent properties. 
These files are declared at the root level of the geometrical model. 

Refer to SYSTEMA User Guide (Chapter 4: “Geometrical Model Management”). 
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3.1 DOSRAD Material Tab 

The user defines material associations via the specific tab of the edition window. DOSRAD
is provided with a default reference material database. However, the user may want to use 
its own material database. In the following figure, the user can associate a material file with 
the application-dependent properties. 

Example 

The Material tab (Figure 2 - DOSRAD material tab) lets the user enter a material filename 
for the physical properties. 

To get access to this window, open the edit window at the root level and unselect “Use 
default material database”. 

Figure 3 -  DOSRAD material tab 

Click  to 
display the window:
DOSRAD material 

Specific tab 

Material 
tab
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Figure 4 -  Material filename 

The “.sysmtr” file contains densities of the materials used in the model (given in kg/m3). 
A material editor accessible from material sub-tab in the SYSTEMA modeller tab allows 
to create or modify the material file. A density is associated with each material defined 
in this file. The materiasl are visible as a green bulleted list. 

DOSRAD is delivered with a reference material database. By default, all newly created 
models will be linked to this reference material database. Use the above procedure to 
attach or create a user defined material database. 

Since version 4.4.2, the material file format has changed. Before version 4.4.2 the 
file extension was “.sysmat”. Opening an existing “.sysmat” file is still possible; 
it will be automatically converted to the new format. 

Click  to select a 
file
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3.2 Applicative Properties 

Applicative properties are specified in the BULK container. This container (BULK) includes 
property sub-groups. 

Some of these sub-groups may globally be assigned by a material. 

Bulk 

This container refers to the internal material settings. 

The following modules are impacted: 

 Dose cartography. 

 Bounding box. 

 Computation point. 

Related properties 

The properties linked to this container are as follows: 

o Geometrical properties (Thickness). 

o Physical properties (Density). 
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Example 

Figure 5 -  Object edition 

Activity 

Here, the question is: 

o Is the surface taken into account in the radiation calculation? 

If the user wants the surface to be taken into account in the radiation calculation, the 
Activity has to be set to “yes”. Otherwise, the Activity has to be set to “no”. The activity 
is thus the answer to the question. 
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Configuration 

Refer to SYSTEMA User Guide (Chapter 4: “Geometrical Model Management”). 

The tabs in DOSRAD have inheritance properties which are identical to those of 
SYSTEMA. It is thus possible to redefine a configuration locally (inheritance removed). 

Example 

You can enter the value at the higher level and make the next level inherit this value 
(default behavior). 

The parameter values can be modified even when in an inheritance configuration.  

In order of priority, a parameter may be affected by: 

 Value overloading (local value). 

 Material overloading. 

 Inherited value (value inherited from the father). 

 Default value. 

The customization option ‘Overload’ lets the user overload the material’s default value. 

Refer to SYSTEMA User Guide (Chapter 4: “Geometrical Model Management”). 
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3.3 Importing a SYSEXP File 

This function allows files (file.SYSEXP) from a previous DOSRAD application (version 3) 
to be imported and to be compatible with a new DOSRAD application (since version 
4.3.0). 

To open the existing model: 

1. Open the Modeler tab in SYSTEMA. 

2. To open the existing model, click the File -> Open menu. 

The Select the file to open dialog box opens: 

Example 

3. In “Files of type”, select Import: SYSEXP file (*.SYSEXP). 

4. Open the “*.SYSEXP” file.  

The model is displayed in the 3D view in the DOSRAD application. 

You can work with the file.  

5. Click the File -> Save menu to save the file as .sysmdl (V4 format). 
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4 Interacting with the Meshing

The way of meshing the model depends on the analysis that will be performed. 

For a dose cartography, a region of the model (or the entire model) will be meshed at surfaces level. 

For a bounding box computation, the meshing consists on creating one or several bounding boxes 
(specific items) which are then meshed. 

For a computation point analysis, the meshing consists on creating one or several computation points 
(specific items). 

The meshing may also contains additional information allowing to modify the way the ray-tracing 
algorithm computes thicknesses when encountering modeled shapes. These additional information are 
stored in specific items, either Volume specific items or Honeycomb specific items. In this case, the user 
has to provide DOSRAD properties to the created specific items. 

4.1 Dose Cartography 

Meshing 

The meshing is associated with an inheritance property and can be accessed from the 
tree structure. 

 Application name: 
Determines the application for which the meshing is performed (useful in case 
DOSRAD is not the sole installed application).

 Meshing type: 
An application may have one or several different processes of meshing surfaces. 

Refer to SYSTEMA User Guide (Chapter 4: “Geometrical Model Management”). 
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The three parameters: “a”, “b”, “c” define the number of desired intervals in a specific 
direction. 

 Parameters “a” & “b”: refer to all two-dimensional elemental surfaces. 

 Parameter “c”: refers to three-dimensional surfaces. 

The following shapes may be distinguished: 

 Triangle, rectangle, quadrangle 

Triangle Rectangle Quadrangle 

 Disk, cylinder, cone, parabola, antenna, sphere 

Parameter Segmentation based on: 

a angular sector 

Parameter Shape Segmentation based on: 

b  disk radius 

cone, cylinder height 

sphere, parabola curvilinear abscissa in iso 

antenna radius 

P1 

P2 P3 
b = 2

a = 3

a = 3

b = 2

P1 P2 

P3 

b = 2

a = 3P1 P2 

P3 P4 
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 Polygons 

o The meshing corresponds to the number of desired intervals in a specific 
direction. This does not apply to the polygon which is a particular case 
because it is divided in triangles and, consequently, only the “a” 
parameter will have an impact as regards the detail of surface 
triangulation. 

 Shape macros and shapes with third dimension 

o Parameters “a” & “b” refer to the basic meshing (see above described 
categories) 

o The “c” parameter completes the meshing in the third dimension. 

Numbering 

It consists in numbering the surfaces for assigning a number to meshes and defining an 
increment value. Actually, it is an incrementation used for the global numbering of the 
model or a sub-part of the model to obtain a mesh network with a meaningful numbering 
system. 

SYSTEMA provides an automatic numbering sufficient for a DOSRAD calculation. 

Inheritance notion: for a numbering, an incrementation is defined. 

Example 

Figure 6 -  Inheritance principle for numbering exemple 

At this level, the following 
parameters have been defined: 
 Submodel Name =Sub1 
 Start Number = 10000 
 Shape Increment = 1000 

 Mesh Increment = 1 

Mesh numbers 
incremented by 1

Shape number 
incremented 

by 1000



Reference: MOS.UM.728639.ASTR 

Issue: 4 

Edition: Feb 2012 

Page: 33 of 116

© Airbus Defence & Space 2023 – All rights reserved. Copying of this document, and giving it to others and the use or communication of the 
contents there-of, are forbidden without express authority. Offenders are liable to the payment of damages. All rights are reserved in the event of the 
grant of a patent or the registration of a utility model or design.

OUTGASSING User

Manual

4.2 Bounding Box 

Meshing 

The bounding box is a virtual box. This virtual box is the target on which sectorial analysis 
will be run (bounding box module). 

The bounding box is defined in the meshing model from one or several shapes of the 
geometrical model. 

To create a bounding box from selection: 

1. Open the required meshing model. 

2. Select one or several shapes of the geometrical model in which you wish to create a 
bounding box. 

3. Via the right click menu, select Create bounding box from selection. 

Result: The bounding box is created. In the browser window, the bounding box is 
positioned under Specific Items. Its name finishes with “bounding box”. One computation 
point is systematically added to this bounding box, located at the center and with the 
same referenced shapes. 

Example 

All parameters describing the virtual target box are defined via a specific dialog box. 
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The following properties, associated with the bounding boxes, could be modified by the 
user: 

 Referenced shapes. 

 Computation point. 

 Box orientation (by default, the axes are parallel to the system frame). 

 Box bounds (the created box is the smallest box including the referenced shapes). 

 Meshing parameters (the default values are 5*5*5). 

How to change the bounding box orientation, size, meshing and referenced shapes 

1. In the browser window, select the required bounding box. 

2. In the right click menu, select Edit. 

To change  the 
referenced 
shapes, 
check/uncheck 
boxes and click 
Add / Remove 
selection 

To change 
the box 

orientation, 
click Add 

To change the 
box bounds, 
click Add 

To change the box orientation 

1. Click . 

2. Change the box orientation parameters. 
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To change the box bounds 

1. Click . 

2. Change the box bounds parameters. 

To validate the modifications 

Click . 

Importing a DOSTAR file 

Only available for the bounding boxes. 

This function allows files (file.DOSTAR) from a previous DOSRAD application (version 3) 
to be imported and to be compatible with a new DOSRAD application (since version 
4.3.0). 

When importing a DOSTAR file, the new bounding boxes are created with the same 
dimensions, positions and meshing. The analysis point is set at the center of the box by 
default, but it can be modified. The names of the new bounding boxes are not imported. 

The creation of a new meshing based on a DOSTAR file is described as follows: 

1. Open the Modeler tab in SYSTEMA. 

2. To open the existing model, click the File -> Open menu. 

The Select the file to open dialog box opens: 

Example 
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3. Select the “*.sysmdl” file. 

4. Click Open.  

The model is displayed in the 3D view in the DOSRAD application. 

5. Open a new meshing by clicking the File -> Meshing-> New menu. 

6. In the Meshing browser window, double click Meshing to edit and set the meshing 
parameters: 

- Application name (DOSRAD). 

- Meshing parameters. 

7. Click Apply. 

8. In the Meshing browser window, select Specific Items.

9. To load the DOSTAR file, via the right click menu, select Load DOSTAR file....

The Select the file to open dialog box opens: 
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Example 

10. Click Open. 

The following information is displayed: 

11. Click OK. 

The DOSTAR file has been imported in the DOSRAD application (version 4). 

12. Click the File -> Save menu to save the file as .sysmsh (V4 format). 

Numbering 

At the bounding box creation, a default numbering is performed by SYSTEMA. 

 Default numbering allocated to the bounding box. 

 Default numbering allocated to the bounding box faces. 
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Example 

When the bounding box meshing is perfomed, a default numbering is allocated to the 
meshing by SYSTEMA. 

Example 

4.3 Computation Point 

Meshing 

The virtual point is the point on which analysis will be run (computation point module). 

The computation point is a virtual point defined in the meshing model by its position and 
referenced shapes. 

To create a computation point from selection: 

Bounding box 
default numbering

Bounding box faces 
default numbering

Meshing default 
numbering
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1. Open the required meshing model. 

2. Select one or several shapes of the geometrical model in which you wish to create a 
computation point. 

3. Via the right click menu, select Create computation point from selection. 

Result: The computation point is created. In the browser window, the bounding box is 
positioned under Virtual nodes. Its name finishes with “computation point”. 

Example 

The following properties, associated with the computation point, could be modified by the 
user: 

- Referenced shapes. 

- Computation point position (the default value is 0,0,0). 

How to change the computation point position and referenced shapes  

1. In the browser window, select the required computation point. 

2. In the right click menu, select Edit. 

To change  the 
referenced shapes, 
check/uncheck 
boxes and click 
Add / Remove 
selection 

To change the 
computation 
point position
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3. To validate the modifications, click  . 

Numbering 

At the computation point creation, a default numbering is performed by SYSTEMA. 

Example 

Computation 
point default 
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4.4 Honeycomb specific item 

Meshing 

The honeycomb specific item is a way to account for honeycomb core panels. 

It is defined in the meshing model by two set of referenced shapes which must be the two 
face sheets of the panel. 

To create a honeycomb from selection: 

1. Open the required meshing model. 

2. Select one or several shapes of the geometrical model representing one of the two 
panel face sheet. 

3. Via the right click menu, select Create specific meshing item -> honeycomb. 

4. A window opens (see Figure below). In the General Tab, in the Face 2 part, select 
the shapes of the geometrical model representing the second panel face sheet 

Figure 7 -  Honeycomb referenced shapes setting 

5. Set the honeycomb properties in the Dosrad tab: nominal panel thickness, foil 
thickness, cell size and density. 

Numbering 

At the honeycomb creation, a default numbering is performed by SYSTEMA. 
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Dosrad Properties 

The properties of the Honeycomb specific item are the following: 

Property Unit 

Nominal Panel Thickness m 
Foil thickness 1/10000 inches 

Cell size inches 
density (of the foils) kg/m3

The nominal panel thickness includes the two face sheets thicknesses. It is the 
sum of the honeycomb core thickness and the two sheets thickness. 

For a geometrical description of the properties, see Figure 2 in the “Computation 
Methods” section of this manual. 

Figure 8 -  Honeycomb properties setting 
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4.5 Volume specific item 

Meshing 

The volume specific item is a way to account for geometrical entities as plain volume (with 
difference to standard shell representation). 

It is defined in the meshing model by a set of referenced shapes which must be the border 
of the volume to represent. 

To create a volume from selection: 

1. Open the required meshing model. 

2. Select one or several shapes of the geometrical model representing the border of the 
volume to account for. 

3. Via the right click menu, select Create specific meshing item -> volume. 

4. A window opens (see Figure below). In the General Tab, it can be checked that the 
correct shapes are referenced. 

Figure 9 -  Volume referenced shapes setting 

5. Set the volume property in the Dosrad tab: the density of the volume has to be input. 

The fact that the shapes referenced by a volume are effectively representing the 
border of a volume is not automatically checked. The user shall thus verify this by 
visual inspection (no hole). 

Numbering 

At the volume creation, a default numbering is performed by SYSTEMA. 
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Dosrad Properties 

The Dosrad property of a Volume specific item is simply the density of the volume to be 
represented. For instance, if the Volume is a box representing a complex equipment, the 
density shall be such that the right mass is accounted for. 

The density can be set either by selecting one of the material defined in the material file 
or by inputting directly a density. 

Figure 10 -  Volume density setting 
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5 Using the Interactive MISSION Module

This Mission module is a basic association module (Geometrical model, Meshing model) making up the 
application inputs. Since version 4.4.2 it is not mandatory to build a mission to perform a radiation 
analysis. 

It is still possible however to build a mission and use it to perform the analysis, although there is no added 
value to do so, because no settings available in the mission will be accounted for by the DOSRAD
modules. 

How to create a mission from a meshing/model pair: 

1. Go to the Mission tab 

2. File -> New, the following  window opens 

3. Either click OK if the suggested model and mission are the one defining the desired 
computation or select the relevant model and/or meshing and then click OK 

4. The mission is set and will be available in the processing tab to be attached to a 
process. 
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6 Using the Interactive PROCESSING 
Module

This module is composed of a sequence of processes, which are specific to the associated application. 

A calculation is defined (mission or meshing selected) and performed (run). 

The analysis that will be performed using the mission or meshing will output the results based on 
Mapping, BoundingBox and ComputPoint modules. 

Refer to SYSTEMA 4.4 User Guide (Chapter 8: “Process Management”). 

The modules are not detailed at this stage. In this User Manual, you will find chapters 
dedicated to the different modules. 

Example 

1. Open the Processing tab in SYSTEMA. 

2. To open a new processing, click File -> New menu. 

Here are the menus proposed in the SYSTEMA Processing tab: 

Figure 11 -  SYSTEMA Processing tab display 
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6.1 Basic Rule 

To display the DOSRAD available processes on the process browser:  

 Click DOSRAD. 

Figure 12 -  DOSRAD modules 

To display a DOSRAD module: 

 Double click (or Drag and Drop) the selected DOSRAD module (Figure 12 - 
BoundingBox module). 

Example

Figure 13 -  BoundingBox module 

Double click  
BoundingBox

module to display 
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To display all the DOSRAD modules, the user has to repeat the task shown on (Figure 12 
- BoundingBox module). The following window displays:  

Figure 14 -  DOSRAD modules 

To display the edit or delete option for each DOSRAD module, as shown on the following 
window, the user can perform the following actions on the selected DOSRAD module: 

 Double click. 

 Right click. 

Figure 15 -  How to get access to the Edit or Delete option of a DOSRAD module 

A double 
click or a 
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Example 

Figure 16 -  Edit or delete option of the DOSRAD BoundingBox module 

 Using the delete option on any DOSRAD module enables the user to make this 
module disappear. 

 As regards the edit option, each DOSRAD module selected has its own run 
parameters. 
The run parameters have always at least two tabs: 

o Ray tracing with its own options depending on the selected module. All 
three modules share at least the choice of the NORM thickness for volume 
method. 

o “Module” computation: “Module” refers to BoundingBox, Mapping or 
ComputPoint depending on the selected module. The “Module” 
computation options are the same for the three modules. 
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Example 

Run parameters available for the ComputPoint Module 
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7 Post-Processing

Refer to SYSTEMA 4.4 User Guide (Chapter 8: “Process Management”, § “Using 
process result”). 

The .h5 files can be used to display the results in the Modeler tab. 

1. Open the Processing tab in SYSTEMA. 

2. Click Load to load the result file (.sysres). 

Example 

7.1 How to Display Results in a 3D View 

Example 

1. Open the Modeler tab in SYSTEMA. 

2. Open the meshing model. 

3. In the 3D view, via the right click menu, select Configuration window. 

4. Select the result file and the property (for example: Dose) you wish to display. 

5. Close the configuration window. 

In the 3D view, the meshing model is displayed showing the result applied to the dose 
calculation. 
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Computation methods
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8 General Method: Shielding Computation

8.1 Overview 

The DOSRAD software evaluates the radiation dose received from space at a mesh or a 
virtual node. For the bounding box module, the point is surrounded by a shielding structure 
(represented by a virtual box). 

The analysis is based on an analytical ray-tracing technique. Rays are traced in all 
directions from the point of interest (the technique depends of the computation module). 
Each ray explores the geometry in one direction. It passes through several objects and 
finally exits the model. A protection thickness and a density are associated with each shape 
of the model. The density is set with the selection of a material or can be modified. 

All 3D and 2D objects are surface entities with no physical thickness (shell surfaces). In 
order to be able to treat the object, the user has to specify the "equivalent-thickness" for the 
study. 

For each launched ray, the ray-tracing gives all the encountered surfaces of the geometrical 
model. 

The dose received on the virtual nodes (bounding box or computation point) or on the 
meshes (dose cartography) is calculated as following: 

 For each of launched rays, the amount of shielding encountered is determined, 
using the radiation geometrical model and taking into account the material density 
(in order to obtain the aluminium-equivalent thickness). 

If one ray encounters no geometrical object but only the space, the user is informed 
on the mesh number where space was directly encountered (the information is given 
in the results file). This allows the user to verify its geometrical model and to consider 
the calculated dose with care. All objects give shielding against radiations except the 
objects linked to the Bounding Box and Computation Point specific items and the 
objects with no activity (see the application properties). Honeycomb and Volume 
specific items modify the shielding provided by their referenced surfaces. 

This procedure is approximate, in that it ignores electron angular scattering and 
bremsstrahlung angular effects, but it is good for ion transport where attenuation is 
virtually in a straight line. 

Depending on the main particles present in the environment, NORM or SLANT 
technique is used to determine the thickness crossed by a ray. 
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Figure 17 -  Thickness computation: NORM and SLANT techniques 

where: 

tNORM : Thickness defined in application properties in the 
geometrical model.

As demonstrated by Monte Carlo validations and analysis on ionising particles 
transport, there is a limited range of application for each of these techniques. Protons 
propagate in straight line while electrons propagate in an erratic way so it is 
recommended to compute proton shielding using SLANT technique and electron 
shielding using NORM technique. 

An equivalent thickness for each ray is then calculated using NORM technique if 
shell sphere dose is used and SLANT technique if solid sphere dose is used. Monte 
Carlo comparisons lead to use the associations SLANT/SOLID SPHERE and 
NORM/SHELL SPHERE. 

These two techniques lead to significantly different estimate of shielding thicknesses. 

 From every aluminium-equivalent thickness on ray, an equivalent dose is 
calculated using the dose depth curve. 

The dose curve is an input either automatically from the DOSE DEPTH CURVE 
application (only available in the V3 version) or directly by the user.  

The dose computation interpolates in the dose depth curve the dose received in each 
direction depending on the encountered thickness.  
The computation of the dose is done by a semi-logarithmic interpolation. 
If the thickness is smaller than the thickness for the first point, the dose 
corresponding to this smallest thickness is taken. 
If the thickness is larger than the thickness for the last point, then the dose 
corresponding to this largest thickness is taken. 

 The average dose per mesh (for the bounding box computation and dose 
cartography) or per computation point (for the computation point module) is then 
calculated considering the dose per ray launched in the considered mesh or 
computation point. 

From dose per ray and the solid angle of meshes and faces (for the bounding box 
computation only), a dose per mesh and per face can be estimated. Each dose per 
face can give an equivalent thickness per face. 
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8.2 Honeycomb specific item 

The DOSRAD software is able to take into account honeycomb panels that may composed 
a spacecraft. 

A honeycomb panel is composed of two face sheets and a core. The face sheets have to 
be modeled as standard shell shapes. Then the two face sheets have to be gathered in a 
specific item for the computation algorithm to account for the core. 

The algorithm to compute the thickness encountered by a ray is modified as follows: 

 If a ray encounter surfaces referenced in only one of the two face sheets of a 
honeycomb specific item, only the corresponding face sheet thickness is 
accounted for. 

 If a ray encounter surfaces referenced in the two face sheets of a honeycomb 
specific item, the two corresponding face sheet thicknesses are accounted for. An 
extra thickness is added to model the presence of all the foils composing the 
honeycomb core (see Figure 2). 

The added extra thickness is dependent on the honeycomb panel properties: nominal panel 
thickness, cell size, foil thickness and density. It depends also on the ray impacting angle 
with respect to the surface normal. The dependence of this additional thickness with the 
impacting angle is based on geometrical consideration. 

The honeycomb core properties are: 

Unit Example 

Nominal Panel Thickness H m 0.02015 

Foil thickness 1/10000 inches 10 

Cell size c Inches 3/16 

density (of the foil) kg/m3 2640 

Figure 18 -  Characteristic honeycomb core properties 

The user has to input the sheet’s thickness and density on the geometrical model whereas 
the honeycomb core properties have to be input in the honeycomb specific item (meshing). 

c
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8.3 Volume specific item 

Usually in ray-tracing radiation analysis tool, spacecraft and/or hardware are geometrically 
represented by shell surfaces, called shapes in SYSTEMA. In some cases, it can be useful 
for the user to represent some parts of the model by a volume rather that by a shape. Since 
version 4.5.0, this is possible, either when using the SLANT or the NORM technique for 
thickness computation. 

A volume in the DOSRAD software is defined by the set of its limiting shapes and a density. 
As such, this is a specific item. 

The algorithm to compute the SLANT thickness encountered by a ray is modified as follows: 

 If a ray encounter surfaces referenced in a volume, the number of these surfaces 
determine if the ray originates from inside the volume (odd number of surfaces) or 
from outside (even number of surfaces). 

 The SLANT thickness is computed as the sum of distances between entering and 
exiting points. 

Of course, the thickness set as DOSRAD properties in the model part are not accounted for 
anymore for the volume’s referenced shapes. 

The fact that the shapes referenced by a volume are effectively representing the 
border of a volume is not automatically checked. The user shall thus verify this by 
visual inspection (no hole). 

It is possible to perform bounding box analysis on a volume. To do so, the surfaces 
referenced by the volume must coincide with the surfaces referenced by the bounding 
box. In this case, the thicknesses generated by the ray / referenced volume interaction 
will not be taken into account. 

The algorithm to compute the NORM thickness encountered by a ray is modified as follows: 

 If a ray encounter surfaces referenced in a volume, the number of these surfaces 
determine if the ray originates from inside the volume (odd number of surfaces) or 
from outside (even number of surfaces). 

 The NORM thickness is computed as the sum of estimated normal distances. 
These minimal distances depend on the user choice concerning the method to be 
used, see figure 3. 

Note that the last method (Cosine Weighted) does not leads to increase in computation 
time, where as the other three necessitate to generate supplementary rays that may cause 
an increase in computation time. 



Reference: MOS.UM.728639.ASTR 

Issue: 4 

Edition: Feb 2012 

Page: 59 of 116

© Airbus Defence & Space 2023 – All rights reserved. Copying of this document, and giving it to others and the use or communication of the 
contents there-of, are forbidden without express authority. Offenders are liable to the payment of damages. All rights are reserved in the event of the 
grant of a patent or the registration of a utility model or design.

OUTGASSING User

Manual

The choice of the NORM method is available in the Ray Tracing tab of each processing 
settings corresponding to the three modules. 
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Method Thickness 

1 (default) Incoming/outgoing Min Path MIN(tSLANT , Ti , To) 

2 Incoming Min Path MIN(tSLANT , Ti) 

3 Weighted Min Path MIN[ tSLANT , 0.5*(Ti+To)] 

4 Cosine Weighted tSLANT *0.5*(cos i + cos o)

Figure 19 -  Computed NORM thickness in the case of impact with a volume 

i

o

tSLANT

Ray 

Incoming normal 
thickness : Ti 

Outgoing normal 
thickness : To 
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9 Dose Cartography

9.1 Theory 

Introduction 

The dose cartography is performed at spacecraft or equipment level for the calculation of 
the total dose received on model meshes. It gives dose mapping on surface whatever 
their shape (cone, cylinder, sphere...). It enables to get a rapid estimation of dose levels 
expected on objects (for mirrors, lenses for example) or to think about the satellite 
agencement in term of radiation impact. 

For all surfaces that are meshed (i.e. spacecraft surfaces and not virtual surfaces), a 
dose mapping is computed. From each mesh, a certain number of rays are launched. 
Both the emission point, i.e. the point in the mesh from which the ray is fired, and the 
emission direction are sampled randomly. From all rays in a mesh, a mean total dose is 
calculated. 

Monte-Carlo ray tracing method 

This is the best method for an accurate modelling. The general principle is: 

 Simulation of the particles behavior by considering the individual history of a small 
number of particles. 

 The particles are sampled randomly from the appropriate emission distribution 
function. 

 The macroscopic behavior is reached statistically after firing a sufficient number of 
particles. 

The computation of the paths followed by the rays within the physical model is called “ray 
tracing”. The ray tracing method takes the Lagrangian point of view by considering the 
individual history of particles from a point of emission. The rays are launched from the 
surfaces of the spacecraft to space, to go back in history of particles. 

Consider the energy emitted from a mesh “m” per unit time to be subdivided into Nm

individual packets. It is assumed that the number of energy packets d Nm emitted from 
any surface element d Am will be in the proportion of the total number of energy packets 
emitted by the mesh “m”: 

m

m

m

m

A

Ad

N

Nd
  (Equation 1) 
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The Monte-Carlo ray tracing method includes the following modelling tasks: 

 Emission of rays from a mesh (only one ray is fired per surface point). 

o Emission points are sampled randomly, according to an iso-distribution 
law, with an analytic definition of shapes. 

o Emission directions are sampled randomly, according to an isotropic 
distribution law over 4  sr. 

 Propagation of rays and search for impacts. 

o The main problem is to determine the surface hit by the ray. 

o An optimized search is needed as it is impossible to test all the surfaces. 

o The ray tracing considers the analytic definition of shapes.  

Surface sampling 

Let  and  be the parameters of the surface. 

It is assumed that any mesh of the surface is associated with a rectangle in the 
parametric space, defined by its limits 1, 2 and 1, 2. 

The procedure for sampling randomly a point belonging to a mesh is equivalent to the 
sampling of two random values for  and , verifying the above-displayed equation 1. 

The method for sampling randomly  and  is presented here. Except for the 
quadrangle, the infinitesimal area d A of a surface can be written as the product of two 
separate functions of  and : 

     dGdFAd 

the equation 1 becomes: 

 

 

 

 

dN d

dt

d

dt
1

2

1

2N

F G


 

  









Ft Gt

.

It clearly indicates that when normalized, F and G represent the distribution functions of 
the random variables  and . 

The computer random generator returns equi-probable numbers valued in [0,1]. Let R 
be such a random number. The value of  is obtained by solving the following equation: 

 

 
R 





F t

F t

d t

d t

1

1

2








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For the quadrangle, it is not possible to separate  and  and the previous technique is 
not easy to implement. 

An alternative technique is to consider rays with a variable energy. Consider again the 
N individual rays (packets of energy) emitted from a mesh, each of different energy, 
d Ek, the above-displayed equation 1 becomes: 

d E

E

d A

A
k k=

1 k N
 (Equation 2) 

if you take    ddAd kkk ,H= , the above equation 2 becomes: 

 dE ddk= H kk

E

A
,

 (Equation 3) 

d Ek appears to be proportional to H ( k , k ). 

Thus, a “statistical weight” proportional to H (, ) is multiplied to the energy of each ray 
emitted from a point in the quadrangle, whose parametric coordinates  and are 
sampled equi-probably and randomly in 

    12 12, ,x
Ray direction sampling 

The ray direction is sampled randomly, based on the distribution function corresponding 
to an isotropic law over 4 sr. Starting from two machine random numbers R1 and R2, 
the angles  (angle with the surface normal vector) and  (angle around the normal 
vector) are computed by: 

12 R 

)1(2arcsin 2  R

Computation algorithm 

The number of rays that are launched from each mesh of the model is determined by the 
user choice. The user can specify a density of rays or a given number of rays. 

For each ray of a mesh, the dose is computed as follows: 
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 Random choice of the emission point and ray direction. 

 Ray-tracing method (propagation of the ray and intersection with surfaces). 

 Equivalent-aluminium thickness computation (two techniques are used NORM and 
SLANT, it depends on the type of the dose curve). 

 Dose computation by interpolating the dose depth curve. 

From all rays of the considered mesh, the average dose is computed and then the 
equivalent-aluminium thickness (by interpolating the dose depth curve). 

The algorithm also includes: 

 The mean thickness computation, for which the dose depth curve is not used. 

 The number of rays that encountered no objects in the model (“void rays”) and the 
number of rays that encountered at least one object with a null thickness (“thick=0 
rays”). 

The surface on which the calculation is performed is not taken into account in the 
calculation, which means that it does not give any shielding for thickness computation. If 
an object or a complex shape, i.e. made of several shapes such as a box, is meshed, 
only the surface on which the emission point is located gives no shielding for its 
computation, whereas the other surfaces (such as the five other faces of a box) give 
shielding to radiation. 
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9.2 Parameters 

This section gives an overview of the windows in this module. 

The parameters set in the different fields correspond to the default values. 

Ray building method: Per mesh Ray building method: Density 

These drop-down lists let the 
user select or not a dose 

calculation technique for the 
mapping 
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The user must at least select a method in accordance with the dose curve data. 

9.3 Input / Output 

In this DOSRAD User Manual, refer to the General Principles in Chapter 2 (DOSRAD 
Modules) for the “INPUT” and “OUTPUT” tables of the different modules and 
corresponding files. 

Input 

 .SYSSET file 

o Mission synthesis file for the DOSRAD application. 

 .DOSE file  

o Description file of the dose depth curve. 

Output 

 MAP.LOG file 

o General information file. 

 MAP.H5 file, RMAP.H5 file 

o Used to display the doses, the thicknesses and possibly the rays that 
have been fired colored by encountered thicknesses. 
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10 Bounding Box Analysis

10.1 Theory 

Introduction 

The bounding box analysis is performed at system level for the computation of the six 
aluminium- equivalent thickness of any equipment for subcontractor specification. These 
six thicknesses represent the shielding given by the satellite to the analysed equipment 
(seen from the computation point). This two-step analysis (system level followed by 
equipment level analysis) allows to handle with less complex model without large data 
exchanges (between system and equipment description). If six aluminium-equivalent 
thicknesses are defined with adequate margins, the equipment level radiation analysis 
may be re-used for all satellite programs. 

Bounding box definition 

The bounding box is defined in the meshing model from one or several shapes of the 
geometrical model. If only one object is selected, the bounding box name is given by the 
selected object followed by "bounding box". By default, the bounding box is defined as 
the smallest box with axes parallel to the system frame including these shapes. The 
default meshing is 5x5 for all faces. Orientation, size, meshing and referenced shapes 
may be changed. 

One computation point is systematically added to this bounding box. By default, at the 
bounding box creation, the attached computation point is set to the bounding box center. 
By default, bounding box referenced shapes are also computation point referenced 
shapes. These attached shapes give no shielding to radiation in the bounding box 
analysis. Computation point position and referenced shapes may be changed. 

Computation algorithm 

The analysis is performed from the computation point of the bounding box. A solid angle 
sectoring technique is used to obtain the dose received at the point of interest. 

The number of rays that are launched from the computation point through each mesh of 
the bounding box is determined by the user choice. The user can specify a surface 
density or a given number of rays. 

For each mesh of the considered bounding box, the analysis is performed as follows: 

 The number of rays in the two dimensions of the mesh can be computed. 

 Computation of the solid angle between the computation point and the mesh. The 
solid angle per face is also updated. 

 For each ray in the two dimensions of the mesh, the dose is computed as follows: 

o Discretization of the mesh: a point is computed (regular distribution of the 
points). 
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o Emission direction (from the computation point to the point of 
discretization). 

o Computation of the elemental solid angle around the ray. 

o Ray-tracing method (propagation of the ray and intersection with 
surfaces). 

o Equivalent-aluminium thickness computation (two techniques are used 
(NORM and SLANT) depending on the type of the dose curve. If M objects 
are encountered along the ray, the thickness ti is as following: 

t  =  ti j
j = 1

M


d j

2 7,

where tj is the j object thickness (NORM or SLANT) and dj is the j object density 
(expressed in g/cm3 in the above equation). 

o Dose computation by interpolating the dose depth curve. 

o Update of the dose per mesh. 

o Mean thickness computation (the dose depth curve is not used). 

o Computation of the number of rays that encountered no object in the 
model (“void rays”) and the number of rays that encountered at least on 
object with a null thickness (“thick=0 rays”). 

 Computation of the thickness for the considered mesh. 

 Dose per face can be estimated. 

Each dose per face gives an equivalent-aluminium thickness per face. The total dose 
received at the computation point is then approximated as: 

 D =  d t
4i

i = 1

n
i





where: 

d(ti) : Dose at the centre of a ti radius aluminium sphere when 
solid sphere dose curve is used. 

Dose at the centre of a ti shell thickness when a shell dose 
curve is used

i : Elemental solid angle around ray i. The sum is over all 
elemental solid angles. 

The equivalent total thickness can also be computed. 

When calculation is made using the solid sphere dose curve and the SLANT technique, 
an automatic calculation is run to evaluate the equivalent-aluminium thicknesses that 
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must be transferred to the subcontractors working with the same method and dose curve 
in order that they get the same total dose on the computation point of their 
equipment. The method is based on dichotomy. The real thicknesses per face to be 
transmitted to subcontractors, called SLANT FOR SUB, are always lower than the SLANT 
thicknesses calculated during the analysis. These thicknesses are deduced from the 
dose per face: 

 
faceface

1-
face D4d=T 

Discretization of a bounding box mesh 

Points corresponding to each ray are equi-distributed on the bounding box meshes. The 
directions of these rays are defined by the line from the computation point position and 
passing through the points on the meshes. The result for the mesh is the average of all 
the results for all rays. 

Figure 20 -  Rays are launched with a regular angular distribution 
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10.2 Parameters 

This section gives an overview of the windows in this module. 

The parameters set in the different fields correspond to the default values. 

Ray building method: Per mesh Ray building method: Density 

These drop-down lists let the 
user select or not a dose 
calculation technique on 

bounding boxes 
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The user must at least select a method in accordance with the dose curve data. 

10.3 Input / Output 

In this DOSRAD User Manual, refer to the General Principles in Chapter 2 (DOSRAD
Modules) for the “INPUT” and “OUTPUT” tables of the different modules and 
corresponding files. 

Input 

 .SYSSET file 

o Mission synthesis file for the DOSRAD application. 

 .DOSE file  

o Description file of the dose depth curve. 

Output 

 BOX.LOG file 

o General information file. 

 BOX.H5 file, RBOX.H5 file 

o Description file of dose calculation results on bounding boxes. Used to 
display the doses, the thicknesses and possibly the rays that have been 
fired colored by encountered thicknesses. 

These drop-down lists let the 
user select or not a results 

detailed in results file. The last 
one allows to activate an extra 
output file (under csv format) 
containing faces information 

results 
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 BOX.OUT file 

o Bounding boxes output file as ASCII format. 

 BOX.CSV file 

o Optional Bounding boxes output file as ASCII / CSV format. 
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11 Computation Point Analysis

11.1 Theory 

Introduction 

The computation point analysis is performed at system or equipment level for the 
estimation of the total dose at one point in the geometrical model. It uses the Monte-Carlo 
ray tracing method. A certain number of rays are launched from the computation point. 
The emission direction is sampled randomly. From all rays, a mean total dose is 
calculated. 

The Monte-Carlo ray tracing method is explained in the “Dose cartography” chapter. The 
difference is that here, the emission points are already set by the user (no surface 
sampling). 

Computation point definition 

The computation point is defined in the meshing model by its position and referenced 
shapes. At its creation, if only one object is selected, the computation point name is given 
by the selected object followed by "computation point". 

By default, its position is set to the system frame origin. There may be zero, one or 
several referenced shapes.  

These referenced shapes give no shielding to radiation in the radiation analysis. 
Computation point position and referenced shapes may be changed. 

Computation algorithm 

The number of rays that are launched from the computation point is specified by the user. 

For each ray, the dose is computed as follows: 

 Random choice of the ray direction. The ray is launched with a randomly isotropic 
distribution over 4  sr (refer to “Ray direction sampling” in “Dose Cartography” 
section 2). 

 Ray tracing method (propagation of the ray and intersection with surfaces). 

 Equivalent-aluminium thickness computation (with NORM and SLANT techniques) 
from all objects encountered along this ray (the method is the same used for the 
dose cartography and the bounding box analysis). 

 Dose computation using the dose depth curve. 
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From all ray contributions, the average total dose is obtained and then the equivalent-
aluminium thickness. 

The algorithm also includes: 

 The mean thickness computation, for which the dose depth curve is not used. 

 The number of rays that encountered no objects in the model (“void rays”) and the 
number of rays that encountered at least one object with a null thickness (“thick=0 
rays”). 
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11.2 Parameters 

This section gives an overview of the windows in this module. 

The parameters set in the different fields correspond to the default values. 

These drop-down lists let the 
user select or not a dose 
calculation technique on 

computation points 
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The user must at least select a method in accordance with the dose curve data. 

11.3 Input /Output 

In this DOSRAD User Manual, refer to the General Principles in Chapter 2 (DOSRAD 
Modules) for the “INPUT” and “OUTPUT” tables of the different modules and 
corresponding files. 

Input 

 .SYSSET file 

o Mission synthesis file for the DOSRAD application. 

 .DOSE file  

o Description file of the dose depth curve. 

Output 

 PT.LOG file 

o General information file. 

 PT.OUT file 

o Computation Point output file as ASCII format. 

 PT.H5 file, RPT.H5 file 

o Description file of dose calculation results at computation points. Used to 
display the doses, the thicknesses and possibly colored by encountered 
thicknesses. 
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Getting Started with 

Dosrad
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12 Introduction

12.1 Overview 

Welcome to DOSRAD Getting Started level course. In this course, you will learn how to 
perform a radiation analysis using the DOSRAD application. 

The Getting Started describes the complete process to perform this analysis. 

It includes the following parts: 

o In the “DosradSat” folder: 

Material definitions for bulk (sysmtr file) 

Complete geometrical model with application 
properties 

(sysmdl file) 

Meshing & numbering associated with the geometry (sysmsh files) 

Mission gathering all previous elements (sysmis files) 

Dose curve file (dose file) 

Process diagram already set to perform the 
DOSRAD modules 

(sysprc files) 

In addition to those files, a sub-folder “Results” contains previously computed results If you 
run the included process, the results will be created in a folder “My_Results” within the 
related SYSTEMA_WORKING_DIR folder. 

These files should not be modified and must be used as references to help completing the 
“MySat” model. 

o In the “MySat” folder: 

Material definitions for bulk (sysmtr file) 

Geometrical model without application properties  (sysmdl file) 

Dose curve file (dose file) 

This folder only includes the basic inputs to start working with DOSRAD. 

The creation of those kinds of files is explained in the Systema v4 Manual and does not 
depend on the DOSRAD application itself. This is why they are considered as inputs in this 
Getting Started. 
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Even if the creation of the geometry itself does not depend specifically on DOSRAD, 
the design of the geometry must comply with the expected radiation dose modeling.
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12.2 The DosradSAT Model 

The DosradSat model is a simplified satellite designed for a simple radiation analysis at 
system level. 

It is composed of: 

o A platform made of HC (honey-comb) walls covered by MLI 

This structure has been modeled using two thicknesses for the two materials. 

o Equipment 

Equipment is made of a surrounding aluminum box. As regards the inner part of the 
equipment, it is represented by a sphere. 

o Radiators 

o A functional instrument 

The instrument presented here is modeled only with inactive shapes. It does not participate 
in the radiation simulation performed here. 

However, some parts of the instrument have been kept active to evaluate the fluxes 
collected by those geometries. 

o Solar panels 

The solar panels are made of sun cells. 
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12.3 In this Chapter 

In a first stage, you will explore the SYSTEMA platform and its functionalities. For that 
purpose, you will perform the following: 

 Open an existing model. 

 Explore the pre-processing options. 

 Load the results. 

 Perform post-processing operations. 

In a second stage, you will learn how to perform the radiation dose analysis described in 
this Getting Started. To do so, you will have to follow these steps: 

 Set the material references. 

 Complete the geometrical model with the applicative properties. 

 Create the meshing. 

 Create the mission. 

 Create a process diagram and run the process. 

For the preliminary steps (creation of geometry, material file, meshing, mission), 
refer to the Systema Getting Started Manual. 
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13 DosradSat

13.1 Introduction 

In this chapter you will start working from an existing model to get familiar with the 
DosradSat environment. 

With the DosradSat model delivered with the DOSRAD software application, you will be 
able to pre-process and post-process data and loading existing results. 

In the sections below you will navigate through SYSTEMA and identify the main functions 
of DOSRAD. 

13.2 Opening an Existing Model 

Using a DosradSat model 

To open the existing DosradSat model: 

1. Open the Mission tab in SYSTEMA. 

2. Click the File -> Open menu. 

The Select the file to open dialog box opens: 

3. Open the *.sysmis file (mapping.sysmis file, for example). 

When you open a file with the Mission tab, all the associated files (geometrical 
model, meshing) open. 
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All the elements of the satellite are graphically represented: 
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13.3 Pre-Processing 

After the model has been loaded, you may want to pre-process the results (e.g. check the 
properties set for the model). 

To open the configuration panel: 

 Right-click the view and select Configuration window. 

Figure 21 -  Pop-up menu 

or 

 Click  in the left corner of the view. 

The 3D View Configuration window opens: 
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Figure 22 -  3D view window 

The data that can be viewed at this stage are as follows: 

o COLOR: 

Refers to the colors defined in the model. 

o Shape orientation: 

Refers to the orientation of faces (the red color is used for positive faces and 
the blue color is used for negative faces). 

o Dosrad: 

Refers to the DOSRAD properties (with the Area, Category and Property 
containers). 

The applicative properties defined in the mission are automatically displayed at this 
stage. 

The grey color in the view means that the property has not been set. 
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13.4 Loading Results 

Loading results related to DosradSat 

You can load results from the result area in the Processing tab. 

Figure 23 -  Result area 

This area includes four buttons with the following functions: 

o Edit 

Used to edit a text file. 

o Import 

Used to import any result file (e.g. an hf5 file). 

o Load 

Used to download a set of results created upon a diagram execution. 

o Unload 

Used to unload the open files. 

These results are available in the Modeler tab. 

13.5 Post-Processing 



Reference: MOS.UM.728639.ASTR 

Issue: 4 

Edition: Feb 2012 

Page: 87 of 116

© Airbus Defence & Space 2023 – All rights reserved. Copying of this document, and giving it to others and the use or communication of the 
contents there-of, are forbidden without express authority. Offenders are liable to the payment of damages. All rights are reserved in the event of the 
grant of a patent or the registration of a utility model or design.

OUTGASSING User

Manual

In the Modeler tab, you will be able to display results on the meshing 

1. Open the 3D View Configuration window by clicking . 

2. According to the results (mapping, boundingbox or computpoint) you want to load: 

Click mapping, boundingbox or computpoint in the Information area list. 

The .h5 files used to pre-process the data are displayed. 

If you select the mapping.map.h5 file, all the elements contained in the mapping results 
display (Property list box). 

Example 

3. Click Close. 

Here you can, for instance, display mapping results. 



Reference: MOS.UM.728639.ASTR 

Issue: 4 

Edition: Feb 2012 

Page: 88 of 116

© Airbus Defence & Space 2023 – All rights reserved. Copying of this document, and giving it to others and the use or communication of the 
contents there-of, are forbidden without express authority. Offenders are liable to the payment of damages. All rights are reserved in the event of the 
grant of a patent or the registration of a utility model or design.

OUTGASSING User

Manual

Example 

Figure 24 -  3D view 
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14 MySat

14.1 Introduction 

Now you are familiar with the different functionalities of the DOSRAD environment, let’s see 
how to create your own model. 

To perform the radiation analysis, you must use the “MySat” model. 

The model is built in accordance with what you want to model. 

The “MySat” model is the model you will create during this tutorial.
The “DosradSat” model is delivered with DOSRAD and can be used for result 
comparison. 

Starting with MySat 

You will start from the geometrical model files including the raw data of SYSTEMA. 

To get access to the model: 

1. Start the SYSTEMA application. 

2. Click the Modeler tab in the lower part of the main window. 

Figure 25 -  Modeler tab 
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3. Click File -> Open -> MySat. 

4. Open the MySat.sysmdl file. 

All the shapes are displayed on an orange background in the model browser: 

Figure 26 -  Model tree structure 
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If you double-click a shape on orange background, a warning displays in the 
Information area. 
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14.2 Setting the Material References 

The applicative properties will be defined from the material file. A default material database 
is embedded within Dosrad, but in this example we assume the user wants to attach its 
own. 

To set the material references: 

1. In the tree structure, double-click the MySat root directory. 

The MySat sysmdl edition window opens: 

Figure 27 -  Edit window 

2. In the DOSRAD tab, click Add to open the Material Filename area. 

3. In the Material Filename area, click  to select the material file. 

4. Select the DosradBulk.sysmtr file. 

5. Click Apply. 



Reference: MOS.UM.728639.ASTR 

Issue: 4 

Edition: Feb 2012 

Page: 93 of 116

© Airbus Defence & Space 2023 – All rights reserved. Copying of this document, and giving it to others and the use or communication of the 
contents there-of, are forbidden without express authority. Offenders are liable to the payment of damages. All rights are reserved in the event of the 
grant of a patent or the registration of a utility model or design.

OUTGASSING User

Manual

Now you will be able to enter the properties using the selected material file. 

14.3 Completing the Geometrical Model 

The general procedure is as follows: 

 Set all the elements to “inherited configuration”. 

 The highest objects will be set to “local configuration”. 

Example 

To enter the properties of the radiators: 

1. In the Models browser, double-click Radiators. 

The edition window dedicated to radiators opens: 

Figure 28 -  Radiators edit window 

2. Enter the Bulk properties. 

At this stage, set the elements to Local configuration. The next elements will be set 
to Inherited configuration. 
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3. Enter the properties for each element. 

To enter the properties, refer to the values in the tables below. 

The elements to be set are as follows: 

o Radiators 

Bulk Configuration Local configuration 

Activity Yes 

Geometrical 
properties 

- Thickness 0.011 

Physical properties Radiator

o Equipment heart 

Bulk Configuration Local configuration 

Activity No 

Geometrical 
properties 

- Thickness 0.001 

Physical properties Select “Aluminium”

o Equipment box 

Bulk Configuration Local configuration 

Activity Yes 

Geometrical 
properties 

- Thickness 0.003 

Physical properties Aluminium
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o MLI ext 

Bulk Configuration Local configuration 

Activity Yes 

Geometrical 
properties 

- Thickness 0.002 

Physical properties MLI

o HC int 

Bulk Configuration Local configuration 

Activity Yes 

Geometrical 
properties 

- Thickness 0.006 

Physical properties HC

o Instrument 

Bulk Configuration Local configuration 

Activity No 

Geometrical 
properties 

- Thickness 0.001 

Physical properties Aluminium

o Optical (below “Ins –Y” and “Ins +Y”) 

Bulk Configuration Local configuration 

Activity Yes 

Geometrical 
properties 

- Thickness 0.009 

Physical properties Optic
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o Solar array 

Bulk Configuration Local configuration 

Activity Yes 

Geometrical 
properties 

- Thickness 0.015 

Physical properties <select material> 

- Density 4832 
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14.4 Creating the Meshing 

Initializing the meshing file 

To initialize a meshing, perform the following steps: 

1. Click the File -> Meshing -> New menu. 

2. In the browser, double-click Meshing. 

The following window opens: 

Figure 29 -  New Meshing edition window 

3. In the Application name area, select Dosrad if necessary. 

4. Click Apply (if necessary). 

Meshing tree structure
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Dose cartography (or Mapping) 

1. Initialize a meshing file (refer to 3.4 “Creating the Meshing”“Initializing the meshing “). 

To create a dose cartography: 

2. In the meshing tree structure, select the shape (New General truncated sphere, for 
instance) of the geometrical model in which you wish to create a dose cartography. 

3. Double-click the shape to edit the meshing parameters. 

The following window opens: 

Figure 30 -  Mapping meshing edition 

4. In the Meshing parameters area, click Add and define a meshing for the shape (for 
instance a 10/20/1 meshing: a, b and c set to 10/20/1). 

5. Click Apply. 
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In the browser, the system creates the elements with an arbitrary numbering. 

You can now save the meshing file you have just created. 

6. In File -> Meshing -> Save as menu, save your meshing file as mapping.sysmsh.

Bounding box 

1. Initialize a meshing file (refer to 3.4 “Creating the Meshing”“Initializing the meshing “). 

To create a bounding box from selection: 

2. In the meshing tree structure, select the shape (New General truncated sphere, for 
instance) of the geometrical model in which you wish to create a bounding box. 

3. Via the right click menu, select Create bounding box from selection. 

Result: The bounding box is created with an arbitrary numbering. In the browser window, 
the bounding box is positioned under Virtual nodes. Its name finishes with “bounding 

Number corresponding 
to the meshes 

Number corresponding 
to the shapes 
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box”. One computation point is systematically added to this bounding box, located at the 
center and with the same referenced shapes. 

4. In the meshing tree structure, double-click the bounding box to edit the meshing 
parameters. 

The following window opens: 

Bounding box tree structure
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Figure 31 -  Bounding box meshing edition 

5. In the Meshing parameters area, click Add and define a meshing for the shape (for 
instance a 20/20/20 meshing: a, b and c set to 20/20/20). 

6. Click Apply. 

In the browser, the system creates the elements with an arbitrary numbering. 

You can now save the meshing file you have just created. 

7. In File -> Meshing -> Save as menu, save your meshing file  
as boundingbox.sysmsh.

Number corresponding 
to the bounding box 
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Computation point 

1. Initialize a meshing file (refer to 3.4 “Creating the Meshing”“Initializing the meshing “). 

To create a computation point from selection: 

2. Select the shape of the geometrical model that will become the referenced shape 
attached to the created computation point. 

3. Via the right click menu, select Create computation point from selection. 

Result: The computation point is created with an arbitrary numbering. In the browser 
window, the computation point is positioned under Virtual nodes. Its name finishes 
with “computation point”. 

Computation point 
tree structure
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4. In the meshing tree structure, double-click the computation point to edit its position. 

The following window opens: 

Figure 32 -  Computation point meshing edition 

5. In the Position area, define a 0/0.9/0 position (X, Y and Z set to 0/0.9/0). 

6. Click Apply. 
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In the 3D view, the system displays the new coordinates of the computation point. 

Figure 33 -  Computation point position 

You can now save the meshing file you have just created. 

7. In File -> Meshing -> Save as menu, save your meshing file as computpoint.sysmsh.

The surface meshing (used for dose cartography), the bounding box and the 
computation point can be created from the same meshing file. 

Numbering setting 

SYSTEMA applies a default numbering sufficient for radiation analyses. It is not 
necessary to set numbering parameters. Furthermore, since version 4.4.2, it is not 
possible to modify the numbering anymore. 

Computation point 
position
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14.5 Creating the Mission 

In this section, you will set all the parameters for the mission. Since version 4.4.2, this part 
can be skipped, as a meshing file can be attached directly to the processing diagram. 

Creating a new mission 

To create the mission, follow these steps: 

1. Open the Mission tab in SYSTEMA. 

2. Click the File -> New menu. 

The Mission browser displays on screen: 

3. In the browser, double-click Mission. 
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The edition window opens: 

Figure 34 -  New Mission edition window 

4. Click the General tab. 

5. In the Geometrical model area, click Add and then  to select the 
MySat.sysmdl file. 

6. Click Apply. 
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In the 3D view, the system displays the geometrical model in the Mission tab 

Figure 35 -  Mission 

Now, you must associate the meshing model with the mission. 

Linking the meshing 

At this stage, the previously created meshing must be associated with the mission. 

To link the created meshing: 

1. In the New Mission edition window, select the DOSRAD tab. 
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The following window displays: 

Figure 36 -  Dosrad tab 

2. Click Add in the Meshing area. 

3. Click  to select the meshing file (mapping.sysmsh, boundingbox.sysmsh or 
computpoint.sysmsh) you have created in the previous section. 

Do not enter the COMPUTATION DATES. 

4. Save the mission file. 
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14.6 Defining a Computation Processing 

Diagram 

In this section, you will create a diagram for computing the results based on Mapping, 
Boundingbox and ComputPoint modules. 

Creating a processing diagram 

To create a processing diagram: 

1. Select the Processing tab in the SYSTEMA window. 

2. Click the File -> New menu. 

3. Click DOSRAD. 

The processing diagram is displayed. 

Figure 37 -  Processing diagram 

You can set each module in the DOSRAD process according to the wished results. 



Reference: MOS.UM.728639.ASTR 

Issue: 4 

Edition: Feb 2012 

Page: 110 of 116

© Airbus Defence & Space 2023 – All rights reserved. Copying of this document, and giving it to others and the use or communication of the 
contents there-of, are forbidden without express authority. Offenders are liable to the payment of damages. All rights are reserved in the event of the 
grant of a patent or the registration of a utility model or design.

OUTGASSING User

Manual

Mapping module 

 In the DOSRAD area, double click Mapping. 

The following processing diagram is displayed: 

BoundingBox module 

 In the DOSRAD area, double click BoundingBox. 

The following processing diagram is displayed: 

ComputPoint module 

 In the DOSRAD area, double click ComputPoint. 

The following processing diagram is displayed: 
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Activating the dose curve file 

6. Via the right click menu of the dose input file, select Edit: 

The dose curve file edition is displayed: 

Figure 38 -  Dose curve file edition 

7. Click  to select the test.dose file. 

8. Click Apply to activate the dose curve file. 
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Running the computing files 

9. Double click the Current Mission, select the wished mission (mapping.sysmis, 
boundingbox.sysmis or computpoint.sysmis) or select “Meshing” in the “Type of 
exported structure” field and select your meshing file: 

If you do not select the mission or meshing, a warning displays and the results 
cannot be computed. 

10. Save the process diagram.  

11. Click . 

The results are saved as per the information in the Result infos area. The files 
created within these results are the result files generated from the diagram and a 
.sysres file corresponding to the data displayed on the diagram. 

If you want to display the results on different processes in the Result area, be 
careful not to overwrite the sysres. file when you generate a result file. 

We recommend to change the result file name for each process. 

You have now created a complete mission and generated the result files. 

To learn more about result management, see the Systema documentation. 
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14.7 Results 

After the run, results and log files are generated. Some of them are created by SYSTEMA. 
These files are: 

 *.sysset: mission synthesis file for DOSRAD (xml format):  

It contains the description of the model and the meshing and it is an input of all the 
computation modules. 

 log.txt (ascii format): information and control file: 

It describes the execution of the launched process. 

 *.sysres: results synthesis file (xml format). 

The results and log files that are generated by each computation module of DOSRAD are 
described below: 

 *.box.log (bounding box) or *.pt.log (computation point) or *.map.log (dose 
cartography): information and control file (ascii format): 

It contains the description of the run parameters and model information. 

 *.box.h5 or *.pt.h5 or *.map.h5: results file (hdf5 format):  

it is used by the post-processing of SYSTEMA for the 3D view of results and it can 
also be loaded into an HDF explorer. The file is structured in three directories: 

o Box meshes or Mapping meshes or Computation points: 

Information on meshes (area, number, name) or computation points (number, 
name). 

o Rays: 

Information on rays launched from meshes or computation points (effective 
launched rays, number of rays that encountered surfaces with a thickness 
equal to zero, number of rays that did not encounter surfaces). 

o Results: 

Dose (in rad) and thickness (in mm) results for each mesh or computation point 
with the selected technique. 

 *.box.out(bounding box) or *.pt.out (computation point): results file (ascii format): 

It is created by the bounding box module and contains the results synthesis 
(aluminium equivalent thickness per bounding box face, total dose and total 
equivalent thickness per bounding box). 

How to display results in a 3D view 

We describe below the procedure to display 3D results for a bounding box computation. 
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1. Open the Modeler tab in SYSTEMA. 

2. In the 3D view, via the right click menu, select Configuration window. 

3. Select the result file and the property (for example: Dose per face) you wish to display. 

4. Close the configuration window. 

Figure 39 -  Dose results per face 

Among the available properties, you can select: 

 Area (information per bounding box mesh). 

 Number of (thick=0) rays per mesh. 

 Number of launched rays per mesh. 

 Number of void rays per mesh. 
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 Dose (result for each bounding box): 

o Per mesh 

o Per face 

o Sub per face (if SLANT technique is chosen, results for Sub-contractors 
are also given) 

o Total and total sub 

 Thickness (result for each bounding box): 

o Per mesh 

o Per face 

o Sub per face 

o Total and total sub 

 Mean thickness 

The names of the results in the Property list are followed by the technique and the 
type of geometry selected. For instance, SLANT technique – Solid sphere. 
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